Posted On October 5, 2022

Virtual Machine Manager Error ID 23351 FirstBootDevice Invalid

kimconnect 0 comments
blog.KimConnect.com >> Codes , Virtualization >> Virtual Machine Manager Error ID 23351 FirstBootDevice Invalid

When moving, importing, exporting Generation 2 template in VMM, the following error occurs when trying to deploy :

The input string "
" for the FirstBootDevice parameter cannot be parsed and may be invalid.
Make sure the string uses one of the following formats: "SCSI,BusId(integer),LunId(integer)" or "NIC,SlotId(integer)"
ID: 23351

Here’s a quick Fix:

Set-SCVMTemplate -Name 'TEMPLATENAME' -FirstBootDevice 'SCSI,0,0'

Better yet, it’s advisable to include the cmdlet above into the importing function of VM templates. A Try-Catch clause with error 23351 keyword could be coded to handle these exceptions during VM provisioning automations.

Leave a Reply

Your email address will not be published. Required fields are marked *

Related Post

User Account Group Membership Copy

This is the quick snippet to be executed in the context of a Domain Administrator:…

PowerShell: Raise Domain Forest Functional Level

# Raise Forest Functional Level$forest=Get-ADForest# 2012R2 LevelSet-ADForestMode -Identity $forest -Server $forest.SchemaMaster -ForestMode Windows2012R2Forest -Force# 2016…

Some AWS Quick Notes

https://docs.aws.amazon.com/vm-import/latest/userguide/vmimport-image-import.htmlOpen Virtual Appliance (OVA) image format, which is compatible with VMware vSphere versions 4 and…
Other project: DragonCoin.com