Connect to the switch via telnet or the serial console and enter config mode
switch# config
Set IP address gateway
ip default-gateway 10.10.10.1
Set hostname and contact details
switch(config)# hostname "2510_01"
2510_01(config)# snmp-server contact "[email protected]"
2510_01(config)# snmp-server location "Headquarter"
Set timezone and network time protocol details
timesync sntp
sntp server 10.10.20.1
sntp unicast
Set timezone offset from GMT in minutes (for PST)
time timezone 800
Enable web management SSL and disable web management plaintext
crypto key generate cert 1024
crypto host-cert generate self-signed
Validity start date [10/21/2012]: <today's date>
Validity end date [10/21/2013]: 10/21/2050
Common name [0.0.0.0]: <switch's IP>
Organizational unit [Dept Name]: Information Technology
Organization [Company Name]: Kim Connect
City or location [City]: Long Beach
State name [State]: California
Country code [US]:US
web-management ssl
no web-management plaintext
Enable SSH and disable telnet
2510_01(config)# crypto key generate ssh
Installing new RSA key. If the key/entropy cache is depleted, this could take up to a minute.
Enable SSH version 2 if supported
2510_01(config)# ip ssh version 2
Enable SSH version 1 if version 2 isn’t supported
2510_01(config)# ip ssh
2510_01(config)# no telnet-server
Set username and passwords
2510_01(config)# password manager user-name kimconnect
2510_01(config)# password operator user-name operator
Set banner
2510_01(config)# banner motd %
#######################################################################
# Authorized Users Only #
# The information on this computer and network is the property of #
# <COMPANY NAME> and is protected by intellectual property #
# rights. You must be assigned an account on this computer to #
# access the information and are only allowed to access information as #
# defined by the System Administrator(s). Your activities are #
# monitored for security reasons. #
########################################################################
%
Set name for interface/s
interface B1-B6 name " "
Save and view the configuration
2510_01(config)# write memory
2510_01(config)# show run
# Set access ports as edge
spanning-tree 1-48 admin-edge-port
# Enable loop protection
loop-protect 1-48
loop-protect trap loop-detected
loop-protect transmit-interval 2 disable-timer 5
# Enable routing ospf
router ospf
enable
area 0
vlan <vlan number>
(Vlan)# ip ospf area 0
(vlan)# router ospf
(ospf)# redistribute connected
COMWARE OSPF
# ospf 1 router-id <x.x.x.x>
(ospf-1)# area 0
(ospf-1-area-0.0.0.0)network x.x.x.x <subnet>
(ospf-1)# import-route direct
#loopback interface
interface loopback 1
ip address 10.10.9.12
# IP load balance
ip route 192.168.50.0/24 192.168.0.1
ip route 192.168.50.0/24 192.168.0.2
Categories: