Posted On December 17, 2020

An Issue with RSA Key On CentOS 8

kimconnect 0 comments
blog.KimConnect.com >> Linux >> An Issue with RSA Key On CentOS 8

Error message seen by checking SSH Daemon status:

[root@linux1 testadmin]# service sshd status
Redirecting to /bin/systemctl status sshd.service
● sshd.service - OpenSSH server daemon
Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2018-12-16 14:28:24 PST; 118h ago
Docs: man:sshd(8)
man:sshd_config(5)
Main PID: 152002 (sshd)
Tasks: 1 (limit: 49018)
Memory: 21.2M
CGroup: /system.slice/sshd.service
└─152002 /usr/sbin/sshd -D [email protected],[email protected],aes256-ctr,aes256-cbc,aes128-gcm@openss>

Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: @ WARNING: UNPROTECTED PRIVATE KEY FILE! @
Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: Permissions 0715 for '/etc/ssh/ssh_host_rsa_key' are too open.
Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: It is required that your private key files are NOT accessible by others.
Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: This private key will be ignored.
Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: Unable to load host key "/etc/ssh/ssh_host_rsa_key": bad permissions
Feb 16 22:39:31 sftp.kimconnect.com sshd[82681]: error: Unable to load host key: /etc/ssh/ssh_host_rsa_key

The Quick Fix:

[root@linux1 testadmin]# chmod 600 /etc/ssh/ssh_host_rsa_key

Leave a Reply

Your email address will not be published. Required fields are marked *

Related Post

Add or Remove a User / Users in CentOS / Redhat Linux

sudo adduser usernamesudo passwd usernamesudo gpasswd -a username wheel#Check wheel groupsudo lid -g wheel#Delete user:userdel…

Quick Note on Tomcat with NGINX

Below is a quick short-hand note to remind oneself to setup proxying properly between Tomcat…

Linux: How to Manually Create a USB Bootable Drive for ESXi

Step 1: Find the USB mount root@kimlinux:/home/kim# ls /dev/s*/dev/sda /dev/sdb1 /dev/sdb3 /dev/sdc1 /dev/sg1 /dev/snapshot /dev/stdin/dev/sdb…
Other project: DragonCoin.com