Posted On July 9, 2020

Hyper-V UEFI Error: The Image’s Hash and Certificate are Not Allowed (DB)

kimconnect 0 comments
blog.KimConnect.com >> Virtualization >> Hyper-V UEFI Error: The Image’s Hash and Certificate are Not Allowed (DB)
Symptom:

Cause:

Secure Boot has been enabled on this generation 2 guest virtual machine. This occurs when a VM has been cloned from a VHDX file using default options of ‘gen2’ para-virtual hardware.

Resolution:

Edit the VM’s setting to remove the check-mark next to ‘Enable secure boot’

Alternatively, run this PowerShell command as Admininistrator:

Set-VMFirmware -VMName $newVmName -DisableSecureBoot

Leave a Reply

Your email address will not be published. Required fields are marked *

Related Post

PowerShell: Remove Hyper-V VM Snapshots

Hyper-V's snapshot feature is a double-edged sword. It's a convenient method to make a quick…

Router Console Methods

Router Console Methods: Configure Management Interface: mgmt intf Reset evaluation period: ssh into ESXi /etc/vmware/vmware.lic…

Dynamics NFS Provisioning in Kubernetes Cluster

Step 1: Creating NFS Server A. Create NFS Share on File ServerThere are many ways…
Other project: DragonCoin.com